Back to all Documentations
Customizely Last Update: May 16, 2020

Requirements

Customizely has only required the latest version of WordPress and the latest version of Google Chrome, Firefox, Edge or Safari browser.